eConnect Error Guide

Error Number = 1189 = taSopHdrRecalc Error = Payment total does not match deposits+payments entered for the document

We usually see this error message when there’s been a modification to the taSopHdrIvcInsertPre stored procedure.

Please check with your IT team to determine if any modifications have been made to this stored procedure. The stored procedure may have also been overwritten during a Dynamics GP update or upgrade. If your IT team is not able to resolve the issue, please contact support@panatrack.com

Error Number = 1356 = taIVTransferHeaderInsert Error = Batch is currently being posted

Site Transfer. The Batch ID assigned to the transaction currently has a status of Marked in GP which will prevent posting of the batch. This may occur when there is automated posting solution enabled and the submit occurs at the time the posting solution is processing the batch.

Re-submit the transaction at a later time or check the Batch status in GP to update to Available.

Error Number = 1379 taIVTransferLineInsert Error = Unit of Measure does not exist for the item.

Site Transfer. This is a rare error. However, if you see this error, review the Unit of Measure Schedule setup for the item. If you recently completed updates to the GP database, you may need to run Checklinks to resolve the error.

Error Number = 1526 taSopSerial Error = Serial Number has already been sold – please choose another Serial Number.

Order Fulfill. The serial number selected on the transaction is marked as sold in GP. This would typically occur if another user selected the same serial in another transaction in GP or that was submitted to GP between the selection of the serial and submit of the order fulfillment back to GP.

You can verify the status of the serial number in GP under the Inventory>>Inquiry>>Serials. Search for the serial number and check if the Alloc flag is checked. You can identify the transaction the serial is currently assigned to through the Serial/Lot Trace in GP.

The serial number selected may need to be deleted from the other transaction holding the allocation OR removed from the current transaction to submit.

Error Number = 1731 = taSopLineIvcInsert Error = Unable to update SOP Header Values

We usually see this error when orders are entered directly into the database, by an eCommerce-type solution. In these instances, Dynamics GP does not have a chance to check the TAXSCHID exists in the schedule for a particular item.

To troubleshoot this, open the order mentioned in the error message, select the line item mentioned, and verify the tax schedules information. If the TAXSCHID does exist, ensure that the syntax is correct, and that there are not any extra spaces in the string. When changes are made, the user should remember to save them, and attempt to resubmit the failed transaction from the portal.

Error Number = 1751 taSopHdrRecalc Error = Tax Schedule does not exist.

The error indicates that something about the tax schedule setup is incorrect. This error most often occurs when a new tax schedule is set up and the setup was not complete.

Review the Tax Schedule Maintenance and confirm the tax detail is setup and linked correctly. If there are no selected tax details assigned, it is most likely the cause.

Error Number = 1757 taSopHdrRecalc Error = Unable to create commissions

The most common cause for this error is related to the company access to the Currency ID. Confirm that multicurrency is setup in GP for the GP company you are connected.

Error Number = 2233 taSopLineIvcInsert Error = QTYFULFI cannot be greater than the line items remaining quantity

This error indicates that the quantity fulfilled by Panatrack exceeds the quantity remaining to fulfill. This may occur in several different circumstances:

— The order pick was completed and left as in-progress for a period of time. At submit, there were other updates to the fulfilled quantity on that sales order making the original picked quantity for this transaction more than the remaining quantity.

— A change was made on the GP sales order for either the order quantity or a canceled quantity after the item was picked but before it was submitted back to GP.

— A second pick on a partially picked order on a Fulfillment type order/invoice may create this error depending on other settings.

Review the current order fulfillment quantity on the sales order in GP and identify the actual remaining quantity to fulfill.
Without edit to the GP sales order, the line item on the failed transaction in the Panatracker portal will need to be deleted. The pick for the remaining quantity (if any) can then be added.
Consider reviewing other transactions submitted for the sales order to determine other pick transactions submitted for the item on that order.

Error Number = 3353 taIVTransferLotInsert Error = Lot Number does not exist.

Site Transfer. This error occurs when the lot selected and being submitted does not exist in GP. It may occur if the lot is selected on another transaction after it was selected on the transfer and before the submit to GP. We have also seen this error thrown when the inventory setup ‘Auto-Assign Lot Numbers Based on” = Expiration Date”. This error then is resolved by setting this to Receipt Date.

Confirm the lot in GP under the Lot Inquiry to the site and bin selected.

Error Number = 3442 Stored Procedure= taSopLineIvcInsert Error Description = Invalid Currency, a Functional currency must be set up

Symptom:

You may receive the following error message on an Order Fulfillment or Pack Order transaction:

Error Number = 3442 Stored Procedure= taSopLineIvcInsert  Error Description = Invalid Currency, a Functional currency must be set up

Solution:

Perform the following steps in Dynamics GP:

Tools>Setup>System>Multi-Currency Access and make sure that the company that you are trying to access has access to Z-US$

Tools > Setup > System > Currency Setup and be sure that Z-US$ is set up

Tools > Setup > Financial > Multicurrency and set up a functional currency

If that does not resolve the issue, please confirm that you have the latest version of eConnect for your Dynamics GP version. 

Error Number = 4612 : Stored Procedure= taPopRcptLineInsert Error Description = Invalid Account Index

Symptom:

When performing a PO receipt through eConnect for Dynamics GP, you receive a message like:

  • “taPopRcptLineInsert Error Description = Invalid Account Index” 
  • or, “INVINDX = Note: This parameter was not passed in, no value for the parameter will be returned.”

Solution: 

Confirm that the PO line is assigned a Purchase Account. If not, the default setting will be used. If there isn’t a default account set up, then this will create an error message. Assign the account on either the PO line or as a default posting accounts in GP and then re-submit. 

Error Number = 7321 Stored Procedure= taPopRcptLineInsert Error Description = Decimal Places passed in on UNITCOST does not match setup

Symptom:

Submitting a Dynamics GP eConnect for a purchase order that does not include a node for UNITCOST for non-inventory items returns an error:

Error Number = 7321 Stored Procedure= taPopRcptLineInsert Error Description = Decimal Places passed in on UNITCOST does not match setup

Other symptoms:

  • Currency decimal places was set to 5 for non-inventory items always received this error.  This error still occurred even when it was set to 2 decimals places (which was the default for the system), a new order was created and submitted.
  • This error did not occur if the decimal place was set to 0, a new purchase order was created and submitted.

Solution:

Multi-Currency was not enabled, but a multicurrency field for a checkbook id was filled in, possibly during set up, and it is not possible to change through the Dynamics GP interface.  Microsoft advised our customer to run the following query:

Update CM00100 set CURNCYID = ” where CHEKBKID = ‘XXXXX’;

This solution should only be used if multi-currency is not enabled; otherwise, you may cause issues with your configuration.

This behavior has been encountered on Dynamics GP 2010 but may also occur on other versions.

Error Number = 8162 Stored Procedure= taPopRcptLineInsert Error Description = Item is an Inventoried Item, the NONINVEN flag is set incorrectly to a 1 for Non Inventoried

Symptom:

Error Number = 8162 Stored Procedure= taPopRcptLineInsert Error Description = Item is an Inventoried Item, the NONINVEN flag is set incorrectly to a 1 for non-Inventoried

Cause:

The item was originally entered on the PO prior to set up as an inventory item in GP; therefore, marked on the PO with a non-inventory flag.  Prior to receiving, the item was then set up as an inventory item in GP. The non-inventory flag is not natively changed on the existing PO. At receiving, the item is validated as an inventory item and not a non-inventory item which throws the error warning.

Solution:

Contact your system administrator to update the PO line non-inventory flag in the database. Alternatively, add a new line on the PO for the inventory item and delete (cancel) the original.

Error Number = 8673 Stored Procedure= taIVMultibinBinToBinTransfer Error Description = Lot number / qty type / location / expiration date combination does not exist in the Bin entered

Symptom:

You may receive the following eConnect error when attempting to perform an Item Bin Move.

Error Number = 8673 Stored Procedure= taIVMultibinBinToBinTransfer Error Description = Lot number / qty type / location / expiration date combination does not exist in the Bin entered 

Cause:

The usual cause of this error is a different time-zone being set up on the handheld unit that recorded the transaction, than the one set up on the application server. The application server or the handheld is translating SQL Server’s “empty” date. Since the GP database cannot store a null (empty) date, it uses 1/1/1900 as a way to mark an empty date. A mismatch of a time-zone will translate the date to one or more hours back; e.g. pulling the date back to 12/31/1899.

Solution:

If you receive the above eConnect error, please confirm that the handheld that recorded the failed transaction has the exact same time-zone setup as the application server. Please also confirm that the application server, and the DATABASE server, are in the same time-zone.

Error Number = 9370 Stored Procedure= taSopHdrIvcInsert Error Description = You are passing a Currency ID in the header and you did not pass the same one to the line

Symptom:

You may receive the following eConnect error when attempting to perform a Verify Order transaction

Error Number = 9370 Stored Procedure= taSopHdrIvcInsert Error Description = You are passing a Currency ID in the header and you did not pass the same one to the line

Solution:

First, please double-check your functional currency setup: Functional Currency Troubleshooting.

Next, please confirm that there aren’t any line items on the order that are blank (i.e. the Item Number field is empty).

If those steps do not resolve the issue, please run the attached query on your GP company database with your Sales Order Number specified, and send the results to us at support@panatrack.com, along with an updated usage file (also attached).

Error Number = 11971 Stored Procedure= taPopRcptLineInsert Error Description = A Prepayment exists for the Purchase Order

Symptom:

You may receive the following eConnect error while attempting to receive a Purchase Order:

Error Number = 11971 Stored Procedure= taPopRcptLineInsert Error Description = A Prepayment exists for the Purchase Order

Cause:

This is because eConnect doesn’t have support to pass prepayment purchase orders through to GP.  Microsoft introduced the Prepayment feature in GP 2013 and did not include a method to update these PO’s with eConnect.  

Solution:
Here are 2 articles/questions posted by other GP users:
https://community.dynamics.com/gp/f/32/t/135405
https://community.dynamics.com/gp/f/32/t/111580

While that has not changed, we recently had another client of ours report that their consultant was able to create a workaround for the issue. If this error is still an issue for your team, we’ve gained permission from that consultant to refer other clients to him for assistance.

If they would like the consultant’s contact info, its:

Larry Ressler
Vice President, Consulting
Keel & Company, LLC
701.371.9945 – M
Email: Larry@keelcompany.com

Error Number = 12013 = taPopRcptLineInsert Error = There is an active Purchase Order Approval workflow

We recommend that you file a ticket with Microsoft or your GP Partner in order to address the error. However, we have had customers report successfully resolving this issue by changing the value in the The Workflow_Status column, in POP10100, from 0 to 9.

An item with the same key has already been added.

Symptom:

Dynamics GP eConnect may throw misleading errors if functional currency is not set up. Examples of such errors are:

  • When a purchase order is submitted, you may get the error: “An item with the same key has already been added.”  
  • When an adjustment is submitted, you may get the error: “Cannot insert the value NULL into column ‘EXTDCOST’, table ‘DATABASENAME.dbo.IV10001’; column does not allow nulls. INSERT fails. (ErrorCode: 515, ErrorState: 2, Procedure: taIVTransactionLineInsert).”

Cause: For these and other errors that do not have an apparent cause, confirm that the functional currency is set up in Dynamics GP.  The eConnect Install Administration Guide for Dynamics GP 2013 (provided by Microsoft here, click Download and select file: eConnectInstallAdminGuide.pdf) states that functional currency is required to be set up for eConnect to function properly. (Page 22)   Solution:   To set the Functional Currency: 

  1. In Dynamics GP, go to Microsoft Dynamics GP >> Tools >> Setup >> Financial >> Multicurrency
  2. If Functional Currency is set up, there should be a value in the Functional Currency field like Z-US$.
  3. If it is not set up, use the look up to view available options and select the appropriate currency and hit OK to save.
  4. The eConnect and Dynamics GP both recommend that Check Links is run at this point.

If the Functional Currency look up was empty:

  1. Close the Multicurrency Setup.
  2. Go to Microsoft Dynamics GP >> Tools >> Setup >> System >> Multicurrency Access.
  3. Under Currencies, select the currency you would like to be available on the Multicurrency Setup screen.
  4. For each company you would like it available for, click the Access check box to make it available.
  5. Click OK and repeat the steps above.
Bin transfer of lot-tracked item after quantity is allocated handled incorrectly by standard Microsoft eConnect

Symptom:

Bin transfer of lot-tracked item after quantity is allocated handled incorrectly by standard Microsoft eConnect

Cause:

Native GP handles Item Bin Moves of allocated lot quantities differently with eConnect than direct entry into GP.  

When a lot with allocated quantities has a portion moved from Bin A to Bin B, the proper behavior is to leave the allocated quantity in Bin A.  Manual entry into GP for this type of transfer properly results in a “split lot”, moving unallocated quantity to Bin B and leaving the allocated quantity in Bin A.  

Solution:

The attached Word document explains the issue.  

Microsoft Sr. Support Engineer Isaac Olson (iolson@microsoft.com) created the attached “updated” eConnect to replace the existing eConnect.  

Here is the content of the email he sent to Panatrack with the fix:

Hi Karl, 

I am just returning from my leave and wanted to get back to you on this.  We don’t have a public facing link to these, as it is an extremely small sample size of customers that would run into this specific situation and our eConnect stored procedures are encrypted by default and are not publicly accessible to view in SQL.  I am however more than happy to send you the “fix” which is an altered eConnect Stored procedure that I sent to the customer so that you can internally document and apply this fix if needed to your customers, since your application would have a higher percentage of users running into this. 

 (UpdatedtaIVMultibinBinToBinTransfer.sql)

 This is the stored procedure responsible for the issue that the customer was having, and each company database has this stored procedure on it, so if you have other customers with this issue, they would need to run the attached altered stored procedure to prevent the issue from happening going forward.  This is provided as-is but worked perfectly for the customer that we were assisting together.  Below I have pasted the information that I had sent to the customer along with the attachments. 

I got this working in my system now for your situation with the split layers.  Essentially, I added a section which I have added my name in the comments on in two places.  At this point I am hoping that this workaround will work for you.  I have written this up for development, but as I mentioned with the low number of customers using this stored procedure the likelihood of a change being made to it at this point is not likely.  Normally in a case once the issue is written up for development we would stop at that point if there is not a straightforward workaround and the case would be closed non-chargeable.  I can understand your urgency for getting this fixed in your environment that is why I have gone a step further in actually modifying the procs in the hopes of a workaround. 

I have attached both the MS modified stored procedure for you to test, and the original unmodified eConnect stored procedure.  I have given you both as that way if you wanted to dig into this further or explore further change to the stored procedures, you will have that flexibility.  I am hoping that with the changes that I have made, that you will not have to do that, but there is a chance. 

The customer came back and confirmed that the issue no longer existed for them after the alterations but the updated procs are provided as-is.

 If a customer upgrades, then their stored procedure will revert back to its original form, so you would want to note that in case you could need to run the updated script again for the fix.

 Let me know if you have any questions!

 Thanks!

Isaac Olson

Sr. Support Engineer – Microsoft Dynamics GP – Email: isolson@microsoft.com

TitlCannot insert the value NULL into column ‘DSCPCTAM’, table ‘XXX.dbo.POP10300’; column does not allow nulls.

Symptom:

Cannot insert the value NULL into column ‘DSCPCTAM’, table ‘XXX.dbo.POP10300’; column does not allow nulls.

Cause:

This error is a result of Discount Type not being defined in the Payment Terms Setup in GP. This needs to be defined even if the Payment Term does not calculate a discount.

Solution:

Access the Payment Terms Setup in GP under Tools>>Setup>>Company>>Payment Terms

Corresponding Table: SY03300 Payment Terms Master


From the Purchase Order, click on the → from the Vendor ID to open the Purchasing Vendor
Detail Entry window. Click on the Payment Terms link. This will also open the Payment Terms
Setup window.

Error Message: Document is currently being edited by another user

Symptom:

Document is currently being edited by another user

Cause:

The error message occurs when an order is open in GP when you attempted to submit the transaction. GP locks the order to prevent any conflicts.

Solution:

Close the order in GP and submit it again from our portal.

Symptom:

Client is getting this error on an Adjustment transaction (assuming it could be any inventory transaction): 

Violation of PRIMARY KEY constraint ‘PKAAG20000’. Cannot insert duplicate key in object ‘dbo.AAG20000’ 

Cause:

This seems to be a common eConnect error in test companies where the Analytical Account set up is incomplete or inaccurate.  It is because the next AA ID for the test company is lower than the next ID in the live company. This causes AA to pass in an ID that already exists to the AAG200000 table and causes the duplicate key error. This next ID is stored in table AAG00102 in the DYNAMICS database. You will need to update the value in this table for the record where aaTableID=20000 and CMPANYID= (your company ID from Table SY01500).

Solution:

This error will require some maintenance on the GP database.  

This error occurs when a company database is cloned and the Analytical Accounting (AA) tables in the DYNAMICS company are not updated to reflect the new company. This causes a duplicate key error with the primary key (aaSubLedgerHdr) on the table AAG20000. For each new row, the value in aaSubLedgerHdr is incremented by 1. When adding a new record, you should use max value in table plus one.

Failed to convert parameter value from a string to DateTime

Symptom:

Failed to convert parameter value from a string to DateTime

Cause:

This error is not a function of the Panatrack software but rather an issue with Microsoft’s eConnect mechanism that integrates to GP. The date that is being rendered is formatted by eConnect and used to call SQL Server stored procedures in the GP database. It takes a regular date and turns it into text so that it can hand it to the stored procedure. The format of that date is determined by the region settings under which the PanatrackerGP portal runs.

Solution:

To change the regional settings under which the portal runs, on the server where PanatrackerGP is installed please do the following:

  • Open Control Panel.
  • Select Clock, Language, and Region.
  • Under Region, select Change date, time, or number formats
  • Ensure the date format is set to match the format of your GP server.
  • On the Administrative tab, select the “Copy settings…” button. Place a check mark next to Welcome screen and system accounts and click OK. This will push the Date/Time settings to the account that runs IIS.
SecurityException: The source was not found, but some or all event logs could not be searched. To create the source, you need permission to read all event logs to make sure that the new source name is unique. Inaccessible logs: State.

The reason you are receiving this error is due to Microsoft locking out applications from making changes to the newly added State event log. There is only one way to resolve this, you must run the Registry Editor as a SYSTEM account to grant the PanatrackerGP application rights to modify the State event log. To do so, please follow the instructions below:

1.    Download PsExec from Microsoft Sysinternals.

2.    Unzip and extract the tool to a permanent folder — e.g., c:\tools

3.    Open an elevated or admin Command Prompt window.

4.    Start the Registry Editor under the SYSTEM account, type the following command, and press ENTER:

c:\tools\psexec.exe -sid c:\windows\regedit.exe

5.    Navigate/expand the following key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\State

6.    Right click on this entry and select Permissions

7.    Add the user “IIS APPPOOL\PanatrackerGP” user and give user Full Control


Once these steps have been done, resubmit the transaction twice and the correct error should appear in the portal.

There was no endpoint listening at net.pipe://localhost/Microsoft/Dynamics/GP/eConnect/EntityOperations that could accept the message.

Symptom:

There was no endpoint listening at net.pipe://localhost/Microsoft/Dynamics/GP/eConnect/EntityOperations that could accept the message

Cause:

This message occurs in Dynamics GP versions of 2010 and later, as the eConnect mechanism was moved to a WCF service.

Solution:

This is usually indicative of eConnect not running on your server. Open “Services” and verify that eConnect is started and running. Verify that the startup is “Automatic” and that the service is currently running.

If your eConnect was working fine and then suddenly stopped with the above error (often following a reboot), the odds are high that you are using an expiring login account for your eConnect service. That means this problem will happen again as soon as the account expires. As stated in the eConnect installation guide, you should set this account to NOT expire, and you should consider minimizing the account privileges.

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