Symptom:
Sequence Contains More Than One Element Error
Cause:
This error happens when completing Order Fulfillment transactions, you might have duplicate Document Numbers assigned to different Types (i.e., one is an order, one is an invoice). This may not be obvious within the GP interface as it is most likely that the invoice transaction has already been posted. Typically posting will move the transaction from the worktables in GP to the history tables; however, that may not always be the case.
Solution:
To fix this error run the Remove Sales Documents utility in GP. This utility will move sales records and remove any document that has no remaining quantities but haven’t been moved to history. Reference the GP user guide for steps on running this utility.
We recommend that your sales documents are set up with a prefix to uniquely identify an invoice from an order type to avoid errors and confusion as sequential numbers is bound to eventually lead to duplication.